SCCM 2012 R2 SP1 Driver Reiter bei Boot Images fehlen – Windows ADK 10

Hallo Zusammen,

beim Update auf den Windows ADK10 während der Migration auf SCCM 2012 R2 SP1 wurden die Windows PE boot Images im SCCM nicht aktualisiert.

Da SCCM im Windows PE bereich die enthaltene Version mit der installierten ADK Version abgleicht und einen Unterschied feststellt, werden die Servicereiter (Images, Drivers etc..) nicht angezeigt.

Um dieses Problem zu beheben hat Henrik Rading auf seinem Blog (http://blog.coretech.dk/hra  | Link zum Artikel) einen Lösungsweg veröffentlicht

(Achtung: Die Pfade müssen je nach Installationsort von Windows ADK und SCCM angepasst werden!)

  1.  Zunächst wird bei bedarf die 64 Bit Wim Datei von D:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Windows Preinstallation Environment\amd64\en-us\winpe.wim nach D:\Program Files\Microsoft Configuration Manager\OSD\boot\x64  kopiert.
  2. Danach wird bei bedarf die 32 Bit Wim Datei von D:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Windows Preinstallation Environment\x86\en-us\winpe.wim nach D:\Program Files\Microsoft Configuration Manager\OSD\boot\x86 kopiert.
  3. In den Verzeichnissen OSD\boot\x86 und OSD\boot\x64 im SCCM Stammverzeichnis muss jeweils die boot.wim gelöscht und die gerade kopierte winpe.wim in boot.wim umbenannt werden.
  4. Powershell script anpassen (Sitecode und jeweils die PackageID des Boot images) und Ausführen:
    $SiteCode = "PRI"
    $PackageID = "PRI00005"
    $BootImage = Get-WmiObject -Namespace "root\SMS\site_$($SiteCode)" -Class SMS_BootImagePackage -Filter "PackageID = '$($PackageID)'" -ErrorAction Stop
    $BootImage.ReloadImageProperties()
    

Danach einmal neu auf den Distributionpoints verteilen und das Problem ist erledigt.

Viele Grüße,

Alexander Volz

Geschrieben von

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.