Archiv für den Monat: Dezember 2014

SCCM Client nach GUID finden

Nach Mac Finden?:  https://volzit.de/2014/11/19/sccm-client-nach-mac-adresse-finden/

Beispielgegebenheiten:

Ein Client versucht ständig einen PXE Boot, kann allerdings nicht zugeordnet werden. Alternativ: Failed to Run Task Sequence | There are no task sequences available for this computer

Problem:

Das liegt oft daran, dass eine GUID/ein Client Doppelt in der Datenbank ist.

Überprüfung:

Wir öffnen unser SQL Studio und erstellen in der Hauptdatenbank eine neue View. Folgender SQL Befehl muss ausgeführt werden:

SELECT TOP (100) PERCENT dbo.v_R_System.Netbios_Name0, dbo.v_RA_System_MACAddresses.MAC_Addresses0, dbo.v_R_System.SMBIOS_GUID0
FROM dbo.v_R_System LEFT OUTER JOIN
 dbo.v_RA_System_MACAddresses ON dbo.v_R_System.ResourceID = dbo.v_RA_System_MACAddresses.ResourceID
WHERE (dbo.v_R_System.SMBIOS_GUID0 LIKE '00000000-0000-0000-0000-000000000000')

(00000000-0000-0000-0000-000000000000 mit der GUID ersetzen)
Nun bekommen wir alle Clients mit dem Namen aufgelistet, die diese MAC haben.

Beheben:

Fall 1 (2 Verschiedene Clients haben die gleiche GUID):

Hierzu muss einer der Clients gelöscht werden. Dazu Namensgebung überprüfen.

 

Fall 2 (Nur ein Client wird angezeigt):

Man öffnet die SCCM Konsole und sucht den Gerätenamen. Nun sollten zwei Objekte angezeigt werden.
Nun in den Details schauen bei welchem der Objekte die GUID vorhanden ist. Das Objekt mit der fehlenden GUID  löschen.

Geschrieben von

WDS USB LAN Adapter | „WdsClient: Fehler beim Abrufen einer IP-Adresse vom DHCP-Server. Stellen Sie sicher, dass in diesem Netzwerksegment ein funktionierender DHCP-Server in betrieb ist“

 

Problem

Ich habe seit dem Release von Windows 8(.1) vergeblich sehr viel Zeit damit verbracht, Broadcom Gigabit Adapter beim aufsetzen über WDS zum laufen zu bekommen.

Aus welchen gründen auch immer, wollen die Windows 8.1 Treiber von Broadcom nicht auf  Windows PE 5.1 funktionieren. Folgende Fehlermeldung erhält man von Windows PE nach dem Booten über PXE: „WdsClient: Fehler beim Abrufen einer IP-Adresse vom DHCP-Server. Stellen Sie sicher, dass in diesem Netzwerksegment ein funktionierender DHCP-Server in betrieb ist“wpid-img_20141201_145543.jpg

 

Lösung

Nun habe ich mir einen USB -> Lan Adapter bei Amazon bestellt. Wichtig ist hier der Chipsatz AX88179 von ASIX. Diese Adapter sind durch die Treiberunterstützung extrem vielseitig einsetzbar und zudem für ca 20€ zu haben.

BSP: http://www.amazon.de/CSL-Ethernet-Netzwerkadapter-Gigabit-Lan-1000Mbps/dp/B00FQM2G1I/ref=sr_1_1?ie=UTF8&qid=1417101618&sr=8-1&keywords=usb3+lan

Update: Folgender Adapter ebenfalls erfolgreich getestet: http://www.amazon.de/gp/product/B00MYTSN7W?psc=1&redirect=true&ref_=oh_aui_detailpage_o02_s00

Die Treiber für das Chipset gibts direkt bei ASIX: http://www.asix.com.tw/products.php?op=pItemdetail&PItemID=131;71;112&PLine=71 

Hier einfach die Windows 8.1 Treiber herunterladen und im WDS über den Treiber Assistent hinzufügen. Dann den PXE Boot am betreffenden Rechner ausführen und sobald das Windows logo erscheint das Netzwerkkabel auf den USB Adapter umstecken, fertig!

Kleiner Hinweis: Manchmal kann es vorkommen dass die USB Treiber noch fehlen (vor allem bei USB 3.0 Steckplätzen). Diese dann einfach auch über den WDS ins Startabbild einfügen. Sonst natürlich erstmal die 2.0 Plätze testen, dann erspart man sich durch Geschwindigkeitseinbuße etwas Arbeit.

 

 

 

Geschrieben von